Trying to help a friend.. lens flare and artifact removal

Questions and answers about processing in StarTools and how to accomplish certain tasks.

Trying to help a friend.. lens flare and artifact removal

Postby OttoMann » Mon Apr 28, 2014 8:00 pm

Hi all..
A friend took his first DSO image the other night. He was all excited till he saw
a lens flare and some weird streak.. think it's from his flats.. a cursor or something?
Anyway he processed in GIMP and I told him he needs to get StarTools!
So I said send me the autosave from DSS and I'll show you what StarTools can do..
Shoulda kept my mouth shut!!
I've never used Heal or Repair or Life and have no clue what I'm doing..
In Repair I create a star mask and click do and then get error messages about my mask or I get a super odd looking result..

Can someone clue me in on how you'd "repair" the star halo and remove the streak..

This has been through the whole process.. not linear.. already been de-noised.. as well as I could...
This was only 15 minutes of lights.. and I think theres something up with his flats.. maybe his monitor refresh rate is super slow?
Anyway.. not expecting miracles.. just a bit of help..

Thanks..

https://www.dropbox.com/s/cmosemljqiwq7 ... Glenn.tiff
OttoMann
 
Posts: 15
Joined: Sat Aug 03, 2013 8:46 pm

Re: Trying to help a friend.. lens flare and artifact remova

Postby admin » Mon Apr 28, 2014 10:34 pm

I don't immediately got an idea of what that streak could be (next to M3, correct?)
Could it be a hot pixel?

There is some horizontal banding as well - makes me think no darks where used (which would fix the banding and any hot pixels).
Try using the Read Noise Compensation setting in the denoise module (only available during tracking) to smoothen out the background. Also run the Color module as one of the last steps (you should be able to get nicer colors that way).

As for fixing defects like these, the module that comes to the rescue is called 'Heal'.
It's pretty easy to use; create a mask with pixels that you want gone and Heal will substitute them for plausible substitutes.

For the streak, Clear any active mask and use the 'Line Toggle (Click & Drag)' brush mode (this is also great for conspicious satellite trails!). Click on one end and hold down the mouse button, move the mouse to the other end and let go. The mask editor will draw a thin (1-pixel) line. Now click 'Grow' a few times until the line is thick enough to cover the whole streak.

s-6.jpg
s-6.jpg (75.66 KiB) Viewed 3516 times


The Heal module will immediately go to work;

s-7.jpg
s-7.jpg (67.91 KiB) Viewed 3516 times


'Keep' the result. Same thing with the halo. I used the Lassoo brush to create an area over the offending pixels;

s-8.jpg
s-8.jpg (42.19 KiB) Viewed 3516 times


The Heal module will immediately go to work again;

s-9.jpg
s-9.jpg (43.68 KiB) Viewed 3516 times


And so, you'll end up with this;

Autosave-M3-StarTools_Glenn.jpg
Autosave-M3-StarTools_Glenn.jpg (87.18 KiB) Viewed 3516 times


Hope this helps!

OttoMann wrote:Hi all..
A friend took his first DSO image the other night. He was all excited till he saw
a lens flare and some weird streak.. think it's from his flats.. a cursor or something?
Anyway he processed in GIMP and I told him he needs to get StarTools!
So I said send me the autosave from DSS and I'll show you what StarTools can do..
Shoulda kept my mouth shut!!
I've never used Heal or Repair or Life and have no clue what I'm doing..
In Repair I create a star mask and click do and then get error messages about my mask or I get a super odd looking result..

Can someone clue me in on how you'd "repair" the star halo and remove the streak..

This has been through the whole process.. not linear.. already been de-noised.. as well as I could...
This was only 15 minutes of lights.. and I think theres something up with his flats.. maybe his monitor refresh rate is super slow?
Anyway.. not expecting miracles.. just a bit of help..

Thanks..

https://www.dropbox.com/s/cmosemljqiwq7 ... Glenn.tiff
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1933
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: Trying to help a friend.. lens flare and artifact remova

Postby OttoMann » Mon Apr 28, 2014 11:41 pm

That's awesome Ivo..
Thanks so much for the help!!
You used my M8 image for that tutorial and I've gotten so much better since thanks to help from you and many others!!

I will try and re-create what you did "healing" my buddys image..
I think he will be a StarTools user in the near future!!
OttoMann
 
Posts: 15
Joined: Sat Aug 03, 2013 8:46 pm

Re: Trying to help a friend.. lens flare and artifact remova

Postby admin » Tue Apr 29, 2014 1:13 am

Here to help! :thumbsup:
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1933
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne


Return to Image Processing Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests