hangs on wipe

Bugs, glitches and unexpected behaviour.

hangs on wipe

Postby Rkonrad » Fri Feb 16, 2018 4:01 pm

Hi Ivo,

I downloaded the most recent version and when I try to do a wipe with gradient or vignetting, it just hangs/never completes. This happens only when I apply a lasso mask. It occurs with both my computers which have different hardware. Both are running linux mint 18.3 cinnamon.

Cheers

Richard
Rkonrad
 
Posts: 133
Joined: Sun Feb 07, 2016 2:55 am

Re: hangs on wipe

Postby admin » Sat Feb 24, 2018 12:07 am

Thank you for reporting this. :thumbsup: I will investigate...
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1734
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: hangs on wipe

Postby admin » Sat Feb 24, 2018 12:11 am

Just tried to replicate this, but no luck....
Would you be able to share a mask + image where this happens for you? Both mask and image can just be a small & heavily compressed JPEGs, uploaded to the forum. I don't think the the actual data would be important for this one...

EDIT: I can see a slight delay, where there is nothing in the status bar (it is healing the image), but on my Machine it only tales a few seconds...
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1734
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: hangs on wipe

Postby Lou » Sun Sep 16, 2018 7:06 am

Hi,
I wanted to report the same problem.
It take up to a few minutes until Starttools keeps going on.
The time depends on object size I am trying to mask out.

greetings
Lou
Lou
 
Posts: 5
Joined: Sat Jul 22, 2017 8:57 am

Re: hangs on wipe

Postby admin » Mon Sep 17, 2018 4:08 am

Lou wrote:Hi,
I wanted to report the same problem.
It take up to a few minutes until Starttools keeps going on.
The time depends on object size I am trying to mask out.

greetings
Lou


Hi Lou,

Though annoying, this does indeed sounds like "expected" behavior. Especially if Wipe only has few samples to work with, this can take a while. Just for reference, what is the resolution of the image you are processing and what are your computer's specs?

Thanks!

Ivo
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1734
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: hangs on wipe

Postby Lou » Mon Sep 17, 2018 8:12 pm

Hi,
FITS file ~64MB 4656x3520
Computer specs:
i7-7500 @2,7Ghz and 16GB RAM Windows 10pro
Lou
 
Posts: 5
Joined: Sat Jul 22, 2017 8:57 am

Re: hangs on wipe

Postby admin » Tue Sep 18, 2018 1:32 am

Lou wrote:Hi,
FITS file ~64MB 4656x3520
Computer specs:
i7-7500 @2,7Ghz and 16GB RAM Windows 10pro


Thanks Lou. That sounds about right unfortunately at that resolution and those specs, especially if you are masking out large portions of the image. The i7-7500U, while very efficient with power usage, is only a dual core CPU and not terribly fast.

Is there a marked difference in Wipe's results if you refrain from masking out the object? At lower Aggressiveness settings it may not matter too much...
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1734
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: hangs on wipe

Postby Lou » Wed Sep 19, 2018 4:31 pm

admin wrote:
Lou wrote:Hi,
FITS file ~64MB 4656x3520
Computer specs:
i7-7500 @2,7Ghz and 16GB RAM Windows 10pro


Thanks Lou. That sounds about right unfortunately at that resolution and those specs, especially if you are masking out large portions of the image. The i7-7500U, while very efficient with power usage, is only a dual core CPU and not terribly fast.

Is there a marked difference in Wipe's results if you refrain from masking out the object? At lower Aggressiveness settings it may not matter too much...


Hi,
Without masking out the object everything runs fast. Also changing the aggressiveness settings does not solve the problem.
Sounds like if I need a new computer :lol:
Should it be a quad or even a octa core ? Also how many RAM makes sense ?

Thanks for your support
Greetings
Lou
Lou
 
Posts: 5
Joined: Sat Jul 22, 2017 8:57 am

Re: hangs on wipe

Postby admin » Thu Sep 20, 2018 8:52 am

Lou wrote:
admin wrote:
Lou wrote:Hi,
FITS file ~64MB 4656x3520
Computer specs:
i7-7500 @2,7Ghz and 16GB RAM Windows 10pro


Thanks Lou. That sounds about right unfortunately at that resolution and those specs, especially if you are masking out large portions of the image. The i7-7500U, while very efficient with power usage, is only a dual core CPU and not terribly fast.

Is there a marked difference in Wipe's results if you refrain from masking out the object? At lower Aggressiveness settings it may not matter too much...


Hi,
Without masking out the object everything runs fast. Also changing the aggressiveness settings does not solve the problem.
Sounds like if I need a new computer :lol:
Should it be a quad or even a octa core ? Also how many RAM makes sense ?

Thanks for your support
Greetings
Lou


Hi Lou,

First see if not masking out the object at all makes a big difference. With a lowered Aggressiveness setting, it may not make much of a difference.
StarTools runs best on desktop CPUs (which are free to draw a lot more power). Of course, stationary desktops aren't always a feasible proposition for everyone.
Truth be told, you already have one of the faster battery-conscious consumer laptops money can buy! 16GB is a good amount of memory - no problems there either.
A quad-core or six-core is probably the price/performance sweetspot for StarTools, as parallelizing gets diminishing returns beyond that in most algorithms StarTools employs.
If you don't have to, don't process at higher resolutions than necessary to convey 1:1 detail. It will greatly speed up processing.

If you can swing it though, you can pick up very powerful ex-office machines for peanuts these days. Especially the OEM systems from Dell, HP, etc. that governments and universities dump after 3 years or so, are perfect for image processing applications that don't rely on a GPU (StarTools does not for various reasons). A 3rd of 4th gen desktop i7 has 4 cores, 8 threads and would perform about 1.5x-2.5x as fast as your laptop, depending on the task.
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1734
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: hangs on wipe

Postby Lou » Sat Sep 29, 2018 5:16 pm

Hi Ivo,
I upgraded my old Desktop PC today and I run a quick test - Laptop vs. Desktop PC.
11min15sec vs. 4min 50sec for the final noise reduction step.

My Desktop PC is operating with 16GB Ram and a AMD Ryzen 5 2600, 6x 3.40GHz processor. No new graphic card.
Very happy with the improvement and no more problems with the "hangs on wipe" :D

CS
Lou
Lou
 
Posts: 5
Joined: Sat Jul 22, 2017 8:57 am

Next

Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 2 guests

cron