Colour Max RGB

Bugs, glitches and unexpected behaviour.

Colour Max RGB

Postby happy-kat » Fri Oct 11, 2019 10:58 am

W10 64 Bit
StarTools_1_6_378
Colour module
switching to MAX RGB and the before images displays as all white.
This can be repeated.

bin|crop|wipe|dev then colour
happy-kat
 
Posts: 200
Joined: Sun Feb 01, 2015 11:31 am

Re: Colour Max RGB

Postby richbandit » Fri Oct 11, 2019 11:27 am

Aha! I didn't try that when I checked out 1.6.378 regards the WIPE process (see other post)!

Yes - I can conform this is the case, I can replicate this every time as well ….

Richard
User avatar
richbandit
 
Posts: 19
Joined: Tue Oct 08, 2019 11:12 am
Location: Chepstow, South Wales

Re: Colour Max RGB

Postby happy-kat » Fri Oct 11, 2019 12:37 pm

A fits file from DSS 3.3.4 (no wb selected process) with linear selected works as expected in colour module and max RGB before after switching.
Issue looks linked to the no white balance opening selection.
happy-kat
 
Posts: 200
Joined: Sun Feb 01, 2015 11:31 am

Re: Colour Max RGB

Postby admin » Sun Oct 13, 2019 1:47 am

Confirmed and "somewhat" fixed in the latest 1.5 Maintenance Release (upgrading highly recommended).

The thing is, the MaxRGB "Before" rendering is perfectly correct (if a bit useless). If it is the first time you are running the Color module while Compose mode is engaged, the "Before" image did will not have had color at all (it showed luminance only), therefore MaxRGB shows all colors to be equal (resulting in a white pixel) for all pixels.

MaxRGB will now show a MaxRGB-analysis of the chrominance data if "Before" is toggled.
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 2203
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 3 guests

cron