Module Synth: "Parameter [UNKNOWN]" in log file

Bugs, glitches and unexpected behaviour.

Module Synth: "Parameter [UNKNOWN]" in log file

Postby firstLight » Thu Feb 27, 2020 3:22 pm

Looking into the log file to check what I did with my image, I unexpectedly discovered missing parameter names in the Synth module. Usually, parameter names are needed to link the name and the value, like here:

Code: Select all
-----------------------------------------------------------
StarTools 1.6.389beta
Wed Feb 26 21:00:47 2020
-----------------------------------------------------------
  [...]
--- Wavelet De-Noise
Parameter [Scale 1] set to [95 %]
Parameter [Scale 2] set to [95 %]
Parameter [Scale 3] set to [95 %]
Parameter [Scale 4] set to [95 %]
Parameter [Scale 5] set to [0 %]
Parameter [Mask Fuzz] set to [1.0 pixels]
Parameter [Scale Correlation] set to [6]
Parameter [Color Detail Loss] set to [12 %]
Parameter [Brightness Detail Loss] set to [12 %]
Parameter [Grain Dispersion] set to [4.5 pixels]
Parameter [Non-linear Response <] set to [Off]
Parameter [Smoothness] set to [65 %]
--- Life
Parameter [Detail Preservation] set to [Linear Brightness Mask]
Parameter [Compositing Algorithm] set to [Power of Inverse]
Parameter [Inherit Brightness, Color] set to [Brightness]
Parameter [Output Glow Only] set to [No]
Parameter [Airy Disk Sampling] set to [128 x 128 pixels]
Parameter [Airy Disk Radius] set to [8 pixels]
Parameter [Glow Threshold] set to [0 %]
Parameter [Detail Preservation Radius] set to [20.0 pixels]
Parameter [Saturation] set to [100 %]
Parameter [Strength] set to [100 %]
Parameter [Mask Fuzz] set to [1.0 pixels]
Mask used (BASE64 PNG encoded)

... while for the Synth module it looks so:

Code: Select all
Parameter [UNKNOWN] set to [Hybrid, Keep Stars]
Parameter [UNKNOWN] set to [0 pixels]
Parameter [UNKNOWN] set to [60 %]
Parameter [UNKNOWN] set to [55 %]
Parameter [UNKNOWN] set to [30 Arc Minutes (19' x 22')]
Parameter [UNKNOWN] set to [0]
Parameter [UNKNOWN] set to [1.0 pixels]
Parameter [UNKNOWN] set to [67 %]
Parameter [UNKNOWN] set to [0.78]
Parameter [UNKNOWN] set to [0 %]
< = > less is more
User avatar
firstLight
 
Posts: 2
Joined: Thu Feb 27, 2020 1:17 pm
Location: Germany

Re: Module Synth: "Parameter [UNKNOWN]" in log file

Postby admin » Fri Mar 06, 2020 3:01 am

Fixed in latest beta. Thanks again for reporting!
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 2203
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest