Linux alpha issue

Bugs, glitches and unexpected behaviour.

Linux alpha issue

Postby HighHo » Fri Jan 09, 2015 8:17 pm

Know its an alpha so unsure how much you are looking for bug reports at the moment, as maybe you already have a big list of known issues :)
When using Linux on selecting a file to open the file browser opens fine for selecting a file, seems to crash (lockup) once a file is selected. I have recreated this on 2 diffrent installs (fine on 1.3 and Windows when using alpha).
Here is the process that seems to cause the lockup:
11290 ? S 0:00 sh -c (while ! wmctrl -F -a "Open" -b add,above;do sleep 0.1;done) & (WINDOWID= && zenity --file-selection --title="Open")
HighHo
 
Posts: 6
Joined: Fri Jan 02, 2015 7:31 pm

Re: Linux alpha issue

Postby admin » Sat Jan 10, 2015 1:17 am

Really appreciate the detailed bug report!

What distro is this, if I may ask? (running "uname -a" will really help as well!)

Could you do me a huge favour and run "zenity --version" for me and tell me what it outputs?
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1543
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: Linux alpha issue

Postby HighHo » Sat Jan 10, 2015 12:29 pm

Was tried on Fedora 21 and Kubuntu 15.04
Below is the outputs from kubuntu
Kernel: 3.18.0-8-generic
Zenity: 3.14.0
HighHo
 
Posts: 6
Joined: Fri Jan 02, 2015 7:31 pm

Re: Linux alpha issue

Postby admin » Sun Jan 11, 2015 11:35 pm

Again, thanks for reporting this.
I downloaded Fedora 21 and was able to replicate the problem.
It was caused by a dependency on wmctrl, which does not exist on Fedora 21 (I develop and test on Linux Mint 17 myself).
I've created a fallback routine in case wmctrl does not exist. StarTools should function as expected now.

Please give 1.4.299 a whirl and let me know if you have further issues!

Thanks again,
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1543
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: Linux alpha issue

Postby HighHo » Sun Jan 11, 2015 11:44 pm

Confirmed working, impressed with the quick turnaround! :)
HighHo
 
Posts: 6
Joined: Fri Jan 02, 2015 7:31 pm

Re: Linux alpha issue

Postby admin » Mon Jan 12, 2015 12:04 am

HighHo wrote:Confirmed working, impressed with the quick turnaround! :)


Good to hear! :thumbsup:
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1543
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest