Mask creating spurious single pixels

Questions and answers about problems with the software, modules or functionality.

Mask creating spurious single pixels

Postby TinySpeck » Thu May 10, 2018 9:45 pm

When I use Mask / Auto / Stars to create a mask, there are a large number of spurious single pixels which appear. These pixels don't seem to have much to do with the image -- they don't look like they're appearing on noise peaks.

Please see the attached video. I'm switching between Shrink and Undo to make the spurious pixels disappear and reappear. You can also see that there are clearly some faint stars which Mask should be picking up. So it is missing stars and creating many spurious pixels.

I've tried a variety of settings in Mask with little effect. I have v1.3.5.289. Please let me know if there's something I'm doing wrong.
Attachments
Mask Single Pixels.zip
(179.18 KiB) Downloaded 33 times
TinySpeck
 
Posts: 6
Joined: Fri Mar 16, 2018 2:02 am

Re: Mask creating spurious single pixels

Postby admin » Mon May 14, 2018 1:41 am

Hi,

Thank you for the MP4 upload.
Unfortunately, without having (a crop of) the actual data, it's hard to tell why the mask generator picks those smaller pixels.
Detecting stars and auto-generating masks isn't an exact science unfortunately.
There are a few ways to increase/decrease sensitivity to particular features. To make it detect fainter stars, for example, you could decrease the Threshold parameter (with Seleciton mode set to "Light Features + Highlight > Threshold") until the fainter stars are detected. Making the Filter Sensitivity parameter smaller will (counter-intuitively) see the generator detect more detail. To avoid the small pixels you could indeed use the method you describe, or you could use two masks;

  • One with "normal" settings and feature size
  • One with feature size set to something low (say 1) and with parameter Old Mask set to "Subtract New from Old". This should turn off any tiny detail in the mask, leaving only the bigger detail.
Hope this helps,
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1734
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: Mask creating spurious single pixels

Postby happy-kat » Fri May 18, 2018 12:32 pm

I have found that is the image is noisy then lots of single none stars are found when doing a mask. If too many pixels are found I just use a shrink then grow to retain the real stars.
happy-kat
 
Posts: 35
Joined: Sun Feb 01, 2015 11:31 am


Return to Software Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest