1.4.297 Alpha

Information on new releases and the latest new features.

1.4.297 Alpha

Postby admin » Mon Dec 29, 2014 1:05 am

* Fixed bug where Synth module would not allow progressing beyond PSF generation
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1512
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: 1.4.297 Alpha

Postby Alvinillo » Wed Dec 31, 2014 3:55 pm

Hi Ivo

I've tested it and I've got no problems. It must be said that I've not done anything creative, that is, develop, wipe, deconvolution, sharp contrast hdr color and noise reduction.

Getting a little off-topic, it continues to exist the rather obscure function in Crop module named StArt. What the hell is it for? If it is supposed to do an auto-crop I must say it generally fails to do it right :D

Regards

EDIT: I've checked the unoffial guide and StArt attempts to detect stacking artifacts :oops:
Alvinillo
 
Posts: 32
Joined: Tue May 13, 2014 7:24 pm

Re: 1.4.297 Alpha

Postby MarcoS » Thu Jan 01, 2015 4:35 pm

Hi Ivo,
I have tested this version with my "problem child" the horsehead nebula and it works nicely, it de-noise much better, with no real noticeable longer times.
And I got an usable image.

The hiccup I encountered is that by saving it tries to save as a .fts and I have to manually change the extension to tiff.

thanks for the update :)
Clear skies
Marco
Meade LS6" ACF, zeroshift focuser, Antares 6.3, 2" TS diag 2"Hyperion 72° 36mm, 2" TS 70° 22mm, 2"TSBarlow Cronuos 68° 1,25" 9 / 4mm, Pyxis LE
Olympus XZ1, EOS1100D, ASI120MC Soft. APT, DSS, StarTools.
User avatar
MarcoS
 
Posts: 44
Joined: Tue Jan 28, 2014 2:25 pm

Re: 1.4.297 Alpha

Postby ancienteyes » Fri Jan 02, 2015 11:58 pm

I certainly had no complaints about the denoise module in 1.3.
In 1.4, I tested it on a noisy DSLR shot of M31, and can detect an improvement.
The module does seem to work a bit longer, but with my hot-rod Win 8.1 machine, it's no problem.
Thank you for your hard work, Ivo!
Attachments
M31_nov14_14_st1.4.jpg
M31_nov14_14_st1.4.jpg (55.11 KiB) Viewed 1549 times
ancienteyes
 
Posts: 10
Joined: Mon Jul 21, 2014 6:52 pm

Re: 1.4.297 Alpha

Postby admin » Sun Jan 04, 2015 12:01 am

Thanks for the feedback guys, much appreciated! :thumbsup:
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1512
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: 1.4.297 Alpha

Postby Alvinillo » Mon Jan 05, 2015 2:55 pm

I've had a problem that, of course, I've not been able to reproduce.

I was finishing an image and, when I disabled tracking and tried to denoise it, it did nothing no matter the denoise values I applied. Not very helpful, i know 8-)

Regards
Alvinillo
 
Posts: 32
Joined: Tue May 13, 2014 7:24 pm

Re: 1.4.297 Alpha

Postby admin » Mon Jan 05, 2015 9:58 pm

Alvinillo wrote:I've had a problem that, of course, I've not been able to reproduce.

I was finishing an image and, when I disabled tracking and tried to denoise it, it did nothing no matter the denoise values I applied. Not very helpful, i know 8-)

Regards


Did you perhaps have a preview area selected while you were in 'Before' (Before/After) mode?

Also, in case you were wondering, I haven't forgotten about your Spanish Translation work! :thumbsup:
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1512
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: 1.4.297 Alpha

Postby Alvinillo » Mon Jan 05, 2015 10:08 pm

admin wrote:
Alvinillo wrote:I've had a problem that, of course, I've not been able to reproduce.

I was finishing an image and, when I disabled tracking and tried to denoise it, it did nothing no matter the denoise values I applied. Not very helpful, i know 8-)

Regards


Did you perhaps have a preview area selected while you were in 'Before' (Before/After) mode?

Also, in case you were wondering, I haven't forgotten about your Spanish Translation work! :thumbsup:


I know what you mean regarding Before/After mode, that has already happened to me :D That was not the case.

About translation, I know there is still a lot of work to do, but it would be nice to have some mechanism to keep help texts updated for new versions.

Regards
Alvinillo
 
Posts: 32
Joined: Tue May 13, 2014 7:24 pm

Re: 1.4.297 Alpha

Postby admin » Mon Jan 05, 2015 10:28 pm

I know what you mean regarding Before/After mode, that has already happened to me :D That was not the case.

Hmmm... Will keep a look out for this bug... :think:

About translation, I know there is still a lot of work to do, but it would be nice to have some mechanism to keep help texts updated for new versions.

As a matter of fact, I've been working on something that does just that. I really hoped to have finished this by now, but things got in the way...
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1512
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: 1.4.297 Alpha

Postby Alvinillo » Mon Jan 05, 2015 11:45 pm

I've checked this new release to find bugs and this is what i got:

- When you open a fit and after you try to save it, it keeps the original name and its extension like "autosave.fit", which leads to an error about Startools only writing jpg and tiff files. Version 1.3 was smarter and automatically added .tiff extension

- Not a bug, but why when I open a grayscale fit Startools keeps answering if it is bayered or not?

- I've attempted to crash it or to get a not working noise reduction and I've failed. Instead I've got another issue. Just load this GRAY image
https://mega.co.nz/#!V1Q1CIhB!ERZ-kxRCV ... 3K2EDNvIOw
Replicate this log
Code: Select all
-----------------------------------------------------------
StarTools 1.4.297
Tue Jan 06 00:13:43 2015
-----------------------------------------------------------
File loaded [E:\Mega\2014_12_20_CAAT_NGC1491\Apilados\NGC1491_LumaSinth.FIT].
---
--- Auto Develop
Parameter [Ignore Fine Detail <] set to [Off]
Parameter [Outside ROI Influence] set to [15 %]
--- Wipe
Parameter [Mode] set to [Correct Color & Brightness]
Parameter [UNKNOWN] set to [Yes]
Parameter [Precision] set to [256 x 256 pixels]
Parameter [Dark Anomaly Filter] set to [1 pixels]
Parameter [Drop Off Point] set to [0 %]
Parameter [Corner Aggressiveness] set to [100 %]
Parameter [Aggressiveness] set to [75 %]
--- Develop
Parameter [White Calibration] set to [Use Stars]
Parameter [Gamma] set to [0.92]
Parameter [Skyglow] set to [0 %]
Parameter [Digital Development] set to [96.27 %]
Parameter [Blue Luminance Contrib.] set to [100 %]
Parameter [Green Luminance Contrib.] set to [100 %]
Parameter [Red Luminance Contrib.] set to [100 %]
Parameter [Dark Anomaly Headroom] set to [5 %]
Parameter [Dark Anomaly Filter] set to [Off]
--- Deconvolution
Parameter [Image Type] set to [Deep Space]
Parameter [Mask Behavior] set to [De-ring Mask Gaps, Hide Result]
Parameter [Radius] set to [1.9 pixels]
Parameter [Iterations] set to [6]
Parameter [Regularization] set to [1.00 (optimal noise and detail)]
Parameter [Mask Fuzz] set to [8.0 pixels]
--- HDR
Parameter [Small Detail Precision] set to [Max]
Parameter [Channels] set to [Brightness Only]
Parameter [Algorithm] set to [Reveal DSO Core]
Parameter [Dark/Bright Response] set to [0.26]
Parameter [Detail Size Range] set to [107 pixels]
Parameter [Noise Suppression] set to [Off]

Undo. (Note. Undoed to Linear, Wiped Deconvolved)

--- Develop
Parameter [White Calibration] set to [Use Stars]
Parameter [Gamma] set to [1.00]
Parameter [Skyglow] set to [0 %]
Parameter [Digital Development] set to [98.06 %]
Parameter [Blue Luminance Contrib.] set to [100 %]
Parameter [Green Luminance Contrib.] set to [100 %]
Parameter [Red Luminance Contrib.] set to [100 %]
Parameter [Dark Anomaly Headroom] set to [5 %]
Parameter [Dark Anomaly Filter] set to [Off]
--- Wavelet De-Noise
Parameter [Scale 1] set to [90 %]
Parameter [Scale 2] set to [90 %]
Parameter [Scale 3] set to [90 %]
Parameter [Scale 4] set to [90 %]
Parameter [Scale 5] set to [85 %]
Parameter [Mask Fuzz] set to [1.0 pixels]
Parameter [Scale Correlation] set to [3]
Parameter [Color Detail Loss] set to [12 %]
Parameter [Brightness Detail Loss] set to [21 %]
Parameter [Grain Size] set to [8.7 pixels]
Parameter [Read Noise Compensation] set to [Off]
Parameter [Smoothness] set to [87 %]
File saved [C:\Users\Alvinillo\Desktop\NGC1491_LumaSinth.jpg].


And I get greenish darks. How is it possible?
NGC1491_LumaSinth.jpg
NGC1491_LumaSinth.jpg (260.32 KiB) Viewed 1499 times


Anyway, great work. Every Startools version is better and more robust
Alvinillo
 
Posts: 32
Joined: Tue May 13, 2014 7:24 pm

Next

Return to New Releases

Who is online

Users browsing this forum: No registered users and 1 guest

cron