Problem with extracting natural color from Image

Questions and answers about processing in StarTools and how to accomplish certain tasks.

Problem with extracting natural color from Image

Postby Andre27 » Fri Mar 08, 2019 1:29 pm

Good Day Ivo

I am having difficulty in extracting or representing natural color in a particular image , what is given is that I image from a very light polluted site and a a flood light about 25 m from my pier. I use a UHC filter that has proven to be very effective in my other images , I have however had a similar issue with the Rosette Nebula which lays in the same direction as the Wide Field Horsehead/Flame nebula which is the image in discussion.
At first I thought is is just bad data but I do not think that is entirely the case.

The image is 13 hours of integration time / 300 & 480 Sec exposures / darks and flats applied.Not white balanced.
Camera Modded Canon 1100d /ccd temp 29 Degree Celsius ave , Stacked in DSS.

Richard has had a go at it for which I am grateful , however the the result are similar to mine , the links below are for two different stacks of the data , I would appreciate if someone could have stab at it.

Restacked
https://drive.google.com/file/d/1l5i-09 ... sp=sharing
Original Stack
https://drive.google.com/file/d/16_h_Ec ... sp=sharing

Thank you for your time ,appreciated.

Andre
Cheers
Andre
Clear Skies To All
Andre27
 
Posts: 3
Joined: Wed Sep 02, 2015 8:54 pm

Re: Problem with extracting natural color from Image

Postby almcl » Sat Mar 09, 2019 6:49 am

Hi Andre27

I have had a go at your data, although I doubt I could do any better than Richard, result below.

What is it in his (and your) image that you find unsatisfactory? Imaging from a light pollution area is difficult (I have similar situation to the one you describe) and any sort of filter is going to upset the colour balance to some extent, but your data looks pretty reasonable to me and very smooth.

Combined Flame pre colour.jpg
before applying the color module
Combined Flame pre colour.jpg (65 KiB) Viewed 692 times


Combined Flame post noise.jpg
after colour and noise reduction
Combined Flame post noise.jpg (82.61 KiB) Viewed 692 times
Skywatcher 200P with an astro modded Canon 700d, cls ccd filter, field flattener, guided by ASI 120, PHD2
almcl
 
Posts: 102
Joined: Wed Jan 21, 2015 7:15 pm
Location: Shropshire. UK

Re: Problem with extracting natural color from Image

Postby Rkonrad » Sat Mar 09, 2019 9:54 am

Nice job with the colour! But I dont get it. This is my result after obtaining a colour balance by sampling the stars. https://www.flickr.com/gp/rkonrad/3MVS38 . Notice how high saturation setting is. I gave up with the colour and just processed it in luminance. Pretty good data considering light pollution. https://www.flickr.com/gp/rkonrad/m1662A.

How did you achieve the colour balance?

Richard
Rkonrad
 
Posts: 164
Joined: Sun Feb 07, 2016 2:55 am

Re: Problem with extracting natural color from Image

Postby almcl » Sat Mar 09, 2019 7:48 pm

Thank you, Richard!

I think (from that very helpful video you posted) that you use a star mask to set the white point in the color module?

I didn't do that on this one but just went straight into the color after the Life module had knocked back the stars a bit. It reduced the red channel rather too much to my eye, so so I reduced the slider slightly and increased the saturation. I then found the black point was a bit too black, so gamma corrected this in the develop module. I still think it's a bit washed out and with more care could probably be improved.

The problem I have with this target is that the light pollution filter that I have to use does distort the colour balance significantly (and this may be so for the OP as well) and so using the stars to set a white balance may not work quite so well.

Be interesting to get Ivo's views on this, too.
Skywatcher 200P with an astro modded Canon 700d, cls ccd filter, field flattener, guided by ASI 120, PHD2
almcl
 
Posts: 102
Joined: Wed Jan 21, 2015 7:15 pm
Location: Shropshire. UK

Re: Problem with extracting natural color from Image

Postby Burly » Sun Mar 10, 2019 7:56 pm

In DSS settings >cosmetic tab have you got hot pixel checked ,try unchecking both hot and cold pixels then restack i see halos around back ground stars and for mre this was the culprit
Burly
 
Posts: 119
Joined: Mon Aug 31, 2015 7:06 am
Location: Northamptonshie uk

Re: Problem with extracting natural color from Image

Postby Andre27 » Mon Mar 11, 2019 11:45 am

Good Day All

Thank you all for the response and advice , I shall re-stack again and perhaps not combine the two different exposure stacks but process them separately and then combine should the shorter exposure image add any value to the image.

After many , many hours of tinkering with this image this what I could get from the data. It is most certainly not on par with other DSLR images I have seen with far less integration time , but I think the high temp of the image frames and the light pollution is the Achilles Heal of this image stack.
I had the same issue with Rosette Nebula which is in close proximity.

I think I am going to overlay Ver 1 over Ver 2 and replace the stars as far as possible and be done with this image should the re stacking and reprocessing not deliver better results.

Thank you again for the assistance

Andre

Ver1.jpg
Ver1.jpg (98.13 KiB) Viewed 645 times


Ver2.jpg
Ver2.jpg (95.97 KiB) Viewed 645 times
Cheers
Andre
Clear Skies To All
Andre27
 
Posts: 3
Joined: Wed Sep 02, 2015 8:54 pm

Re: Problem with extracting natural color from Image

Postby Rkonrad » Mon Mar 11, 2019 2:14 pm

Hi Andre,

I'm not sure which programme you used to stack but if you used DSS it's important not to select "white balance". Not sure if you responded to my previous question on that.

Cheers

Richard
Rkonrad
 
Posts: 164
Joined: Sun Feb 07, 2016 2:55 am

Re: Problem with extracting natural color from Image

Postby admin » Mon Mar 11, 2019 11:38 pm

Andre27 wrote:I use a UHC filter that has proven to be very effective in my other images , I have however had a similar issue with the Rosette Nebula which lays in the same direction as the Wide Field Horsehead/Flame nebula which is the image in discussion.


First off, color balancing data that has been acquired through a UHC filter will be fundamentally impossible to color balance - parts of the spectrum are missing, for example;

Image

That said, in most cases decent hints of color (pertaining to different star temperatures, reflection and emission types) can still be recovered.

It appears your dataset has indeed been filtered by some filter. Below is the default color balance the Color module came up with (for Restacked version);
Combined Flame 300 And 480 13hours N0 drizzle.jpg
Combined Flame 300 And 480 13hours N0 drizzle.jpg (244.3 KiB) Viewed 633 times


It shows red H-alpha emissions, and the orange glow of the flame nebula. Blue reflection nebulosity is visible and some star color (mainly just orange and blue) is visible.
To be clear, I did not touch the color balance (it is honestly rarely needed).


300 & 480 Sec exposures

Please don't mix different exposure lengths. It has an adverse effect on noise propagation and star shapes.

The image above was very lightly processed, just to get to the Color module.
--- Bin
Parameter [Scale] set to [(scale/noise reduction 35.38%)/(798.89%)/(+3.00 bits)]
Image size is 1517 x 1010
--- Crop
Parameter [X1] set to [108 pixels]
Parameter [Y1] set to [86 pixels]
Parameter [X2] set to [1490 pixels (-27)]
Parameter [Y2] set to [959 pixels (-51)]
Image size is 1382 x 873
--- Wipe
Default
Parameter [Dark Anomaly Filter] set to [6 pixels]
--- Auto Develop
Parameter [Ignore Fine Detail <] set to [1.9 pixels]
Parameter [RoI X1] set to [236 pixels]
Parameter [RoI Y1] set to [240 pixels]
Parameter [RoI X2] set to [925 pixels (-457)]
Parameter [RoI Y2] set to [699 pixels (-174)]
--- Color
Parameter [Dark Saturation] set to [6.90] to introduce more color into the darker regions.
Parameter [Saturation Amount] set to [248 %]
Parameter [Blue Bias Reduce] set to [1.03]
Parameter [Red Bias Reduce] set to [4.89]
--- Wavelet De-Noise
Default
Parameter [Grain Size] set to [7.1 pixels]

Hope this helps at all...
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
admin
Site Admin
 
Posts: 1667
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne

Re: Problem with extracting natural color from Image

Postby Andre27 » Tue Mar 12, 2019 8:45 am

Thank you Ivo

I am going to re stack with settings suggested by the participating forum and give it another go.

Yesterday I had a meeting with the municipality and I am hopeful that the three streetlights closes to my property are going to be replaced with shorter poles and light heads that shine down instead off lighting up my backyard and all the trees in the vicinity.

Perhaps then I should be able to use a LP filter that allows for easier editing of my data and is less restrictive as far as color manipulation is concerned.

Thank you for your assistance , it is appreciated.
Cheers
Andre
Clear Skies To All
Andre27
 
Posts: 3
Joined: Wed Sep 02, 2015 8:54 pm


Return to Image Processing Troubleshooting

Who is online

Users browsing this forum: No registered users and 0 guests

cron