Page 1 of 2

Small star cores are green - what am I doing wrong?!

Posted: Mon Sep 07, 2020 5:21 pm
by F-Astro
Hi,

Relatively new user of Startools. I use an Esprit 100 ED refractor with an ASI294MC Pro OSC camera. All looks well in my processing (to me) until I get to the color module. When I run the color module, my large star colors seem OK, however the smaller star cores are green.

I use Deep Sky Stacker and follow Ivo's recommended parameters.

Can anybody point me in the right direction please?

Many thanks
Fran
2020-09-07_12-17-20.jpg
2020-09-07_12-17-20.jpg (150.96 KiB) Viewed 412 times

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 1:32 am
by admin
Hi Fran,

Green cores are usually caused by 1. alignment issues of the channels, 2. stacker dealing incorrectly with highlights (usually only a problem with DSLR datasets) or 3. chromatic aberration in your optical train

Given the stellar profile I can see in your image, I'm inclined to think we're dealing with #3.

If you would be able to upload the dataset somewhere (Google Drive, One Drive, WeTransfer, etc.) and publish the public link, we can have a look at whether this suspicion is correct and advise on counter measures.

Thank you in advance!

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 4:19 am
by F-Astro
Hi Ivo,

Thank you for looking at this for me, it is very much appreciated. My imaging train consists of only the SkyWatcher field flattener made for the Esprit scopes, a couple of ZWO spacers, and the camera. Exposure time was 60 seconds; about two hours worth. Flats , dark flats, and darks used to calibrate. ASI294MC Pro using gain of 120, cooled to -10C. No filters used. Here is a link to my stacked file from DSS.

https://drive.google.com/drive/folders/ ... sp=sharing

Thanks again,
Fran

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 5:13 am
by admin
Many thamls for uploading that Fran.

This is an odd one. The stellar profiles look nothing like an Airy disc. There is a distinct "second plateau". It's almost like two different exposure times (or gains) were mixed?
Selection_196.png
Selection_196.png (7.71 KiB) Viewed 396 times
and
Selection_195.png
Selection_195.png (20.23 KiB) Viewed 396 times
Do all light frames look roughly the same? Or are there one or more light frames that are brighter or dimmer than the others?
Is the focus roughly the same for all light frames? Another cause may be loss of focus during the night, or some other event that all of a sudden spread the light across the image more (high clouds, significant changes in transparency or atmospheric turbulence, smoke, etc.) See if all frames roughly have the same quality in terms of FWHM in DSS.

It is trivial to to fix or hide this in the Color module, but ideally we'd get to the bottom of what is happening here.

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 9:23 am
by happy-kat
In DSS ensure hot pixel removal is not selected on the Cosmetic tab when stacking, I had thought this could cause the centre of the star to be spots, like the images Ivo shared.

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 3:31 pm
by F-Astro
admin wrote: Tue Sep 08, 2020 5:13 am Many thamls for uploading that Fran.

This is an odd one. The stellar profiles look nothing like an Airy disc. There is a distinct "second plateau". It's almost like two different exposure times (or gains) were mixed?

Selection_196.png

and

Selection_196.png

Do all light frames look roughly the same? Or are there one or more light frames that are brighter or dimmer than the others?
Is the focus roughly the same for all light frames? Another cause may be loss of focus during the night, or some other event that all of a sudden spread the light across the image more (high clouds, significant changes in transparency or atmospheric turbulence, smoke, etc.) See if all frames roughly have the same quality in terms of FWHM in DSS.

It is trivial to to fix or hide this in the Color module, but ideally we'd get to the bottom of what is happening here.
Hi Ivo,

Thanks are to you for taking your time to look, not to me! I did take a look at everything you mentioned and although not perfect, things looked pretty good. I did actually forget to add my auto focus in my NINA sequence, and some high clouds did indeed make their way over by the end of the night. No bright frames and FHWM scores between 3.12 - 3.7. Not perfect, but not bad. I ran a couple of tests limiting the data but no luck.

Going to do quick test with happy-kat's suggestion now ... Will keep all informed.

Fran

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 3:58 pm
by F-Astro
happy-kat wrote: Tue Sep 08, 2020 9:23 am In DSS ensure hot pixel removal is not selected on the Cosmetic tab when stacking, I had thought this could cause the centre of the star to be spots, like the images Ivo shared.


happy-kat, I owe you a beer! Many thanks for helping.

I think your suggestion re not Detecting & Cleaning Hot Pixels on the DSS Cosmetic tab did the trick. Below is an apples-to-apples comparison.
Stack with Cleaning Hot Pixels parameter set to ON and then restacking and setting it to OFF. Data and all other DSS parameters identical. STarTools processing the same for both datasets.

All default parameters. CROP->AUTODEV_>WIPE->AUTODEV->COLOR. Images shown after second AUTODEV and then after COLOR.

Have to show in two posts - can't upload 4 images in same post

BEFORE COLOR MODULE

HOT PIXEL CLEAN = ON
Hot Pixel Cleaned.jpg
Hot Pixel Cleaned.jpg (239.82 KiB) Viewed 383 times
HOT PIXEL CLEAN = OFF
No Hot Pixel Clean.jpg
No Hot Pixel Clean.jpg (207.59 KiB) Viewed 383 times

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 4:06 pm
by F-Astro
I think that was it - cores look normal (to my inexperienced eyes).

happy-kat :bow-yellow:



AFTER COLOR MODULE

HOT PIXEL CLEAN = OFF
NO Hot Pixel Cleaned color.jpg
NO Hot Pixel Cleaned color.jpg (255.72 KiB) Viewed 383 times
HOT PIXEL CLEAN = ON
Hot Pixel Cleaned color.jpg
Hot Pixel Cleaned color.jpg (317.22 KiB) Viewed 383 times

Re: Small star cores are green - what am I doing wrong?!

Posted: Tue Sep 08, 2020 4:15 pm
by happy-kat
that's great that looks better now, glad it helped

Re: Small star cores are green - what am I doing wrong?!

Posted: Wed Sep 09, 2020 1:44 am
by admin
That's amazing @happy-kat! I would never have thought it was a DSS issue. I added this to the "recommended DSS settings" page. Thank you! :bow-yellow: