Help with M42 + CLS filter

Questions and answers about processing in StarTools and how to accomplish certain tasks.
Post Reply
mgutierrez
Posts: 23
Joined: Sat Oct 24, 2020 11:07 pm

Help with M42 + CLS filter

Post by mgutierrez »

Hi all!

Last night I was trying my last toys; autoguiding and a svbony cls filter. I started to play with M42. I got a very few lights (dithered) and a few flat files (dark flats as well).
Although my dataset is quite poor, my intention was only to test both autoguiding (I have to finetune) and the cls filter, and view the results with Startools. Here you can find the, I repeat, poor, stacked fits file (with dss, startools recommended settings).
I know that I have to practice a lot with this image, and that finally I won't get excellent results, but I don't care; I only want to clarify some concepts. I've loaded the into startools and I have the impression that I'm doing something wrong. The dataset is poor but I think the main problem is the workflow I'm following to deal with the color due to the use of the cls filter.
I read in another thread about how to deal a decent color balacing with a dual filter (optolong l-enhance) and I decided (maybe wrongly) to apply the same workflow. I loaded the image as composed with the same fit file in the red, blue and green channel. Then, I set "Luminance, Color" setting to "L + Synth L From R(2xG)B, R(GB)(GB) (Bi-Color from OSC/DSLR).
This is the stacked fits file: https://www.dropbox.com/s/z9ndwhosp5h5s49/M45.fts?dl=0
I'm using a Nikon D3300, by the way.
And this is a fast processing:
NewComposite_01.jpg
NewComposite_01.jpg (319.89 KiB) Viewed 59 times
Basically, is correct the approach I'm doing with the color and loading the image?

Thanks in advance.

m
Carles
Posts: 13
Joined: Thu Jul 30, 2020 5:06 pm

Re: Help with M42 + CLS filter

Post by Carles »

Hi mgutierrez,

I had a go at your datasheet. ST v 1.7449
I have an Optolong L-pro ,althought is perhaps less restrictive as your CLS or L-enhance.
I did the same workflow I would do for my images with L-pro + OSC

Load as single file, linear. Crop 1pixel left/right and up/down, and bin to 40% (basically, my laptop is old and slow, so wanted to cut down the file and speed up the process) and Wipe to default with 4pixel. AutoDev with Roi on M42.
Then Contrast, HDR first to Reveal Core, keep, then again HDR to Tame highlights a bit.
Star Mask, inverted then Sharp, I didn't use Decon as I was just trying to get to the Color module as priority.
In color module, I kept the inverted star mask and after Color did its own thing, I clicked Sample and got this Red and Greenish core (as M42 core supposed to be ) Changed to Artistic detail aware and pumped the saturation a bit.
Then Super structure module to Saturate. After, did another star mask, this time selecting the stars no the background, and in Color module keep Mask and Sample. Got some stars colors back to "normal" but yellow is hard as it might be left out by the filter. I did a bit more Sharp and Denoise

Probably there's better ways to do it or to get better results. But hope it helps :D

Carles.
Attachments
M45 Done.jpg
M45 Done.jpg (282.48 KiB) Viewed 50 times
mgutierrez
Posts: 23
Joined: Sat Oct 24, 2020 11:07 pm

Re: Help with M42 + CLS filter

Post by mgutierrez »

Hi Carles,

Thanks for your help.
So, is it not necessary to use the compose module as I read in another thread with the l-enhance filter? I understand that the cls is also a dual filter, but broader.

m
mgutierrez
Posts: 23
Joined: Sat Oct 24, 2020 11:07 pm

Re: Help with M42 + CLS filter

Post by mgutierrez »

Hi again,

I had another try and this is the result:
NewComposite2_01.jpg
NewComposite2_01.jpg (462.24 KiB) Viewed 33 times
And this is the workflow I followed:
Sun Nov 22 17:08:38 2020
-----------------------------------------------------------
Loading red channel data
File loaded in LRGB module [Autosave007.fts].
Loading green channel data
File loaded in LRGB module [Autosave007.fts].
Loading blue channel data
File loaded in LRGB module [Autosave007.fts].
--- Compose
Parameter [Luminance, Color] set to [L + Synth L From RGB, R(GB)(GB) (Bi-Color)]
Parameter [Color Ch. Interpolation] set to [On]
Parameter [Lum Total Exposure] set to [Not set]
Parameter [Blue Total Exposure] set to [1h00m (60m) (3600s)]
Parameter [Green Total Exposure] set to [1h00m (60m) (3600s)]
Parameter [Red Total Exposure] set to [1h00m (60m) (3600s)]
Image size is 5969 x 3975
Type of Data: Linear, was not Bayered, or was Bayered + white balanced
--- Auto Develop
Parameter [Ignore Fine Detail <] set to [Off]
Parameter [Outside RoI Influence] set to [15 %]
Parameter [RoI X1] set to [0 pixels]
Parameter [RoI Y1] set to [0 pixels]
Parameter [RoI X2] set to [5969 pixels (-0)]
Parameter [RoI Y2] set to [3975 pixels (-0)]
Parameter [Detector Gamma] set to [1.00]
Parameter [Shadow Linearity] set to [50 %]
--- Crop
Parameter [X1] set to [25 pixels]
Parameter [Y1] set to [25 pixels]
Parameter [X2] set to [5331 pixels (-638)]
Parameter [Y2] set to [3106 pixels (-869)]
Image size is 5306 x 3081
--- Wipe
Parameter [Synthetic Dark/Bias] set to [Off]
Parameter [Gradient Edge Behavior] set to [Absorb 50%]
Parameter [Synthetic Flats] set to [Off]
Parameter [Sampling Precision] set to [256 x 256 pixels]
Parameter [Dark Anomaly Filter] set to [2 pixels]
Parameter [Gradient Falloff] set to [92 %]
Parameter [Synth. Bias Edge Area] set to [100 %]
Parameter [Gradient Aggressiveness] set to [75 %]
--- Bin
Parameter [Scale] set to [scale 50.00% / +2.00 bits / +1.41x SNR improvement]
Image size is 2653 x 1540
--- Auto Develop
Parameter [Ignore Fine Detail <] set to [Off]
Parameter [Outside RoI Influence] set to [15 %]
Parameter [RoI X1] set to [1200 pixels]
Parameter [RoI Y1] set to [293 pixels]
Parameter [RoI X2] set to [1792 pixels (-861)]
Parameter [RoI Y2] set to [1074 pixels (-466)]
Parameter [Detector Gamma] set to [1.00]
Parameter [Shadow Linearity] set to [50 %]
--- Contrast
Parameter [Expose Dark Areas] set to [No]
Parameter [Compensate Gamma] set to [No]
Parameter [Precision] set to [256 x 256 pixels]
Parameter [Dark Anomaly Filter] set to [2 pixels]
Parameter [Aggressiveness] set to [50 %]
Parameter [Dark Anomaly Headroom] set to [50 %]
--- HDR
Parameter [Small Detail Precision] set to [Max]
Parameter [Channels] set to [Brightness Only]
Parameter [Algorithm] set to [Optimize Soft]
Parameter [Dark/Bright Response] set to [Full]
Parameter [Detail Size Range] set to [1000 pixels]
Parameter [Strength] set to [1.2]
--- HDR
Parameter [Small Detail Precision] set to [Max]
Parameter [Channels] set to [Brightness Only]
Parameter [Algorithm] set to [Reveal DSO Core]
Parameter [Dark/Bright Response] set to [Full]
Parameter [Detail Size Range] set to [1000 pixels]
Parameter [Strength] set to [1.1]
Undo
Image size is 2653 x 1540
--- Wavelet Sharpen
Parameter [Structure Size] set to [Large]
Mask used (BASE64 PNG encoded)
--- SNR-aware Wavelet Sharpening
Parameter [Scale 1] set to [100 %]
Parameter [Scale 2] set to [100 %]
Parameter [Scale 3] set to [100 %]
Parameter [Scale 4] set to [100 %]
Parameter [Scale 5] set to [100 %]
Parameter [Mask Fuzz] set to [4 pixels]
Parameter [Amount] set to [300 %]
Parameter [High SNR Size Bias] set to [85 %]
Parameter [Low SNR Size Bias] set to [0 %]
Parameter [Dark/Light Enhance] set to [50% / 50%]
Mask used (BASE64 PNG encoded)
--- Deconvolution
Parameter [Image Type] set to [Deep Space]
Parameter [Secondary PSF] set to [Off (Primary Only)]
Parameter [Primary PSF] set to [Moffat Beta=4.765 (Trujillo)]
Parameter [Primary Radius] set to [1.5 pixels]
Parameter [Iterations] set to [11]
Parameter [Error Diffusion] set to [Off]
Parameter [Mask Fuzz] set to [8.0 pixels]
Parameter [Deringing] set to [50 %]
Mask used (BASE64 PNG encoded)
--- Color
Parameter [Bias Slider Mode] set to [Sliders Reduce Color Bias]
Parameter [Style] set to [Artistic, Not Detail Aware]
Parameter [LRGB Method Emulation] set to [RGB Ratio, CIELab Luminance Retention]
Parameter [Matrix] set to [HOO Duoband 100R,50G+50B,50G+50B]
Parameter [Dark Saturation] set to [2.0]
Parameter [Bright Saturation] set to [4.7]
Parameter [Saturation Amount] set to [277 %]
Parameter [Blue Bias Reduce] set to [2.36]
Parameter [Green Bias Reduce] set to [2.36]
Parameter [Red Bias Reduce] set to [1.01]
Parameter [Mask Fuzz] set to [1.0 pixels]
Parameter [Cap Green] set to [0 %]
Parameter [Highlight Repair] set to [Off]
--- Super Structure
Parameter [Detail Preservation] set to [Linear Brightness Mask]
Parameter [Compositing Algorithm] set to [Screen]
Parameter [Brightness, Color] set to [Only Color]
Parameter [Brightness Retention] set to [Off]
Parameter [Mask Fuzz] set to [1.0 pixels]
Parameter [Airy Disk Radius] set to [50 %]
Parameter [Gamma] set to [0.27]
Parameter [Detail Preservation Radius] set to [40.0 pixels]
Parameter [Saturation] set to [200 %]
Parameter [Strength] set to [100 %]
--- Filter
Parameter [Filter Mode] set to [Conservative Nudge]
Parameter [Sampling Method] set to [3x3 Average]
Parameter [Filter Width] set to [5]
Parameter [Mask Fuzz] set to [1.0 pixels]
--- Entropy-driven Detail Enhancement
Parameter [Resolution] set to [Medium]
Parameter [Channel Selection] set to [All]
Parameter [Strength] set to [100 %]
Parameter [Midtone Pull Filter] set to [20.0 pixels]
Parameter [Midtone Pull Strength] set to [50 %]
Parameter [Dark/Light Enhance] set to [50% / 50%]
--- Wavelet De-Noise
Parameter [Grain Size] set to [3.8 pixels]
Parameter [Walking Noise Size] set to [1.0 pixels]
Parameter [Walking Noise Angle] set to [0]
--- Wavelet De-Noise
Parameter [Grain Size] set to [6.2 pixels]
Parameter [Walking Noise Size] set to [1.0 pixels]
Parameter [Walking Noise Angle] set to [0]
--- Wavelet De-Noise
Parameter [Scale 1] set to [95 %]
Parameter [Scale 2] set to [95 %]
Parameter [Scale 3] set to [95 %]
Parameter [Scale 4] set to [95 %]
Parameter [Scale 5] set to [50 %]
Parameter [UNKNOWN] set to [10 %]
Parameter [Scale Correlation] set to [50 %]
Parameter [Color Detail Loss] set to [50 %]
Parameter [Uniform Grain Retention] set to [50 %]
Parameter [Grain Dispersion] set to [6.2 pixels]
---
Parameter [UNKNOWN] set to [Small]
Mask used (BASE64 PNG encoded)
--- Fractal Flux
Parameter [Brightness Mask Mode] set to [Off]
Parameter [Algorithm] set to [Modulate Unsharp Mask]
Parameter [Negative Flux] set to [0 %]
Parameter [Positive Flux] set to [500 %]
Parameter [Detail Filter] set to [1.0 pixels]
Parameter [Filter Fuzz] set to [1.0 pixels]
Parameter [Filter Radius] set to [1.5 pixels]
Parameter [Filter Amount] set to [200 %]
Parameter [Mask Fuzz] set to [1.0 pixels]
Parameter [Brightness Mask Power] set to [1.0]
Mask used (BASE64 PNG encoded)
File saved [NewComposite2.tiff].

I would please need some tips and suggestions about this workflow, which I'm sure it can be improved or even it's completely wrong from the beginning, regarding the compose module, mainly.
Also, regarding the compose module, I would like to know and understand the logic behind composing in this way when using a narrowband filter (even if it does not apply to this case), cause to be honest I don't know why do I need to load the channels in this way, and why to set the luminance to that option. I saw it in a thread talking about other filter. I don't know if this applies to this case, but in any case I would like to really understand the real logic.

Thanks a lot.

m
Carles
Posts: 13
Joined: Thu Jul 30, 2020 5:06 pm

Re: Help with M42 + CLS filter

Post by Carles »

Hi Mgutierrez,

it looks better indeed :D
and you're right, your filter is a dual band, So I guess the workflow has to be specific.
Although you've used "bicolor" and there's a mode in Compose for "Bicolor from OSC/DSLR"
maybe that'll yield better results?
Let's hope someone can bring bright into this :)

Carles.
mgutierrez
Posts: 23
Joined: Sat Oct 24, 2020 11:07 pm

Re: Help with M42 + CLS filter

Post by mgutierrez »

Carles wrote: Sun Nov 22, 2020 6:16 pm Hi Mgutierrez,

it looks better indeed :D
and you're right, your filter is a dual band, So I guess the workflow has to be specific.
Although you've used "bicolor" and there's a mode in Compose for "Bicolor from OSC/DSLR"
maybe that'll yield better results?
Let's hope someone can bring bright into this :)

Carles.
Yes, in fact the compose mode I used was the dslr specific, the same I put in the first post, although the log doesn't reflect that
Post Reply