StarTools 1.8.512 public alpha/preview 4 now out

General discussion about StarTools.
User avatar
admin
Site Admin
Posts: 2861
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: StarTools 1.8.506 public alpha/preview now out

Post by admin »

Ok. I'm a dunce.

I downloaded 1.8.506 on a Windows machine. Indeed, it produces the aberrant pixels.
Then I tried my current development version on that Windows machine. Pixels are gone.

The thing is, I have no recollection of any changes I made between 1.8.506 and the current dev version that would have made a difference, and hence I've been trying my hardest to replicate the issue on a version that is - apparently - not exhibiting the issue.

Either some code fairy fixed the issue in the meantime, or my sleep-deprived brain made a fix for this and can't remember. I'd like to think it was the former, but it's probably the latter (which is a worry). :P

At any rate, I will release a new version before the weekend. Thanks again for helping me ferret out the issue!
alacant wrote: Tue Aug 03, 2021 8:30 am Yes, i couldn't get it to crash with this version. Must try harder!
Not too hard though. :D
Ivo Jager
StarTools creator and astronomy enthusiast
Mike in Rancho
Posts: 117
Joined: Sun Jun 20, 2021 10:05 pm

Re: StarTools 1.8.506 public alpha/preview now out

Post by Mike in Rancho »

Awesome! :D

I imagine we were all going to zero in on that soon. I myself was starting to wonder if maybe you had put the 506a you intended to into the download package. Not quite the same, but in the ballpark.

My last shot earlier tonight was to try an AMD machine - an old Toshiba that is now my guiding laptop. Some kind of Turion x64 and a Radeon X1200. GPU wouldn't run, just too old I guess. So I plodded through non-GPU and got the pixels.

So yeah, I guess we can all just go back to trying to force general crashes now. :lol:
User avatar
admin
Site Admin
Posts: 2861
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: StarTools 1.8.510 public alpha/preview 2 now out

Post by admin »

Version 1.8.510 is now available in the download section.

Have a great weekend all!
Ivo Jager
StarTools creator and astronomy enthusiast
xonefs
Posts: 16
Joined: Sun Jul 18, 2021 7:30 am

Re: StarTools 1.8.510 public alpha/preview 2 now out

Post by xonefs »

admin wrote: Fri Aug 06, 2021 4:00 am Version 1.8.510 is now available in the download section.

Have a great weekend all!
Thank you for your hard work!
xonefs
Posts: 16
Joined: Sun Jul 18, 2021 7:30 am

Re: StarTools 1.8.510 public alpha/preview 2 now out

Post by xonefs »

I am currently still sometimes getting crashes on an m1 macbook air 16gb. They seem random and at different times, this last time it was using the wipe module after adjusting the dark anomaly filter. Usually it occurs on loading files into compose.
Mike in Rancho
Posts: 117
Joined: Sun Jun 20, 2021 10:05 pm

Re: StarTools 1.8.510 public alpha/preview 2 now out

Post by Mike in Rancho »

admin wrote: Fri Aug 06, 2021 4:00 am Version 1.8.510 is now available in the download section.

Have a great weekend all!
I'm liking 510 so far (Windows). :thumbsup:

The wild-pixel free (thanks code fairy) SVD is so good you can get a very nicely enhanced/resolved image even just going straight to deconv.

Got it Thursday night (weekend? Oh yeah, international date line) and have been through a good number of different datasets without issue. Not that I exercise it too hard, as I just stick to a fairly routine workflow.

:obscene-drinkingcheers:
domenico03
Posts: 1
Joined: Sat Aug 07, 2021 11:43 pm

Crash on 1.8506

Post by domenico03 »

Hi,
Whenever I finish and turn off tracking the program will crash and close. Is this happening to other people as well? I am using a Mac. Thank you
Carles
Posts: 122
Joined: Thu Jul 30, 2020 5:06 pm

Re: Crash on 1.8506

Post by Carles »

HI Domenico,

version 1.8510 is up already. try that one ...maybe it works better for you

CS

Carles.
User avatar
admin
Site Admin
Posts: 2861
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: StarTools 1.8.510 public alpha/preview 2 now out

Post by admin »

domenico03 wrote: Sun Aug 08, 2021 8:12 pm Hi,
Whenever I finish and turn off tracking the program will crash and close. Is this happening to other people as well? I am using a Mac. Thank you
This should definitely not be happening. Is this 100% replicable?
Are you sure you are not mixing different versions of the executables and 'resources' file? (please make sure you extract and overwrite all files!)
xonefs wrote: Sun Aug 08, 2021 2:00 am I am currently still sometimes getting crashes on an m1 macbook air 16gb. They seem random and at different times, this last time it was using the wipe module after adjusting the dark anomaly filter. Usually it occurs on loading files into compose.
Thank you for letting me know.
Mike in Rancho wrote: Sun Aug 08, 2021 4:16 am
admin wrote: Fri Aug 06, 2021 4:00 am Version 1.8.510 is now available in the download section.

Have a great weekend all!
I'm liking 510 so far (Windows). :thumbsup:

The wild-pixel free (thanks code fairy) SVD is so good you can get a very nicely enhanced/resolved image even just going straight to deconv.

Got it Thursday night (weekend? Oh yeah, international date line) and have been through a good number of different datasets without issue. Not that I exercise it too hard, as I just stick to a fairly routine workflow.

Excellent news! :D
Ivo Jager
StarTools creator and astronomy enthusiast
Mike in Rancho
Posts: 117
Joined: Sun Jun 20, 2021 10:05 pm

Re: StarTools 1.8.510 public alpha/preview 2 now out

Post by Mike in Rancho »

Well, I crashed 510. I am filled with shame. :cry:

Windows GPU, during SVD sampling. I was perhaps pushing a little hard, but not really really hard.

Uncertain if particulars matter? It was a compose of Ha-as-L R G B. DSLR so the Ha was a prior red channel strip of bicolor filter stack. Same file of the unfiltered stack was loaded into each of RGB. 6K x 4K files. Then cropped and binned 50%. Wipe, A/D, HDR, SVD.

It worked out so I broke the image up in to 8 subsections, and was picking 2 stars in each. But in the very last section I selected a third after finding a better placed star, realized it needed expansion from 15x15 to 17x17 so did that, and then clicked one of the stars to deselect it --- poof!

I wasn't clicking fast, but I could hear the system fan was humming at about medium. Back in 505 I was more cautious when the machine was churning like that and ST was thinking away, but it had seemed 506 had cleared that up.
Post Reply