[LINUX] error while loading shared libraries: libOpenCL.so

Questions and answers about problems with the software, modules or functionality.
Post Reply
Troy Galebach
Posts: 30
Joined: Fri Dec 28, 2018 8:31 pm

Re: 1.8 closed alpha feedback

Post by Troy Galebach »

admin wrote: Sat Jun 19, 2021 1:36 am Hi all,

For those wishing to share feedback on the closed alpha - in particular the NBAccent and SVDecon modules, your comments, logs, results (before/after) and/or datasets are much appreciated!

Please feel free to share them here, via PM or via email.

I will endeavor to address any and all feedback here publicly, or privately (if contacted via PM or email).

Thank you!
Well, I question my ability to use this website :oops: . I ran into a problem loading the closed alpha today. My error message indicated
error while loading shared libraries: libOpenCL.so.1: cannot open shared object file: No such file or directory.


So I poked around and found what I think is the file the program is looking for in /usr/lib/x86_64-linux-gnu

Well I found a link to that program at any rate. Where is the program looking for said library, and how would you suggest I go about a fix? I hate to change the locations of things since I don't know what I may break.

Regards,
Troy




Well that isn't quite true Ivo. I searched for that library and found it in
User avatar
admin
Site Admin
Posts: 2861
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

[LINUX] error while loading shared libraries: libOpenCL.so

Post by admin »

Hi Troy,

To run any GPU version of StarTools, you will require an OpenCL compatible driver for your video card.
I believe the latest drivers from nVidia should support your card.
Alternatively you could run the CPU-only version, but you'd be missing out some some significant speedups.

Hope his helps,
Ivo Jager
StarTools creator and astronomy enthusiast
Troy Galebach
Posts: 30
Joined: Fri Dec 28, 2018 8:31 pm

Re: [WANTED] 1.8 alpha test subjects!

Post by Troy Galebach »

Okay, I do have the NVIDIA X Server installed , I think that gives me a driver for the GPU. What I see when I try to start it from the Command line is this:
./StarTools-Linux64-GPU: error while loading shared libraries: libOpenCL.so.1 : cannot open shared object file: No such file or directory
I think I found the file yesterday, but now can't remember for certain. I may just have found a link to it. I have to swap computers as this is a new one so I have to change video cable and mouse back to my old system which is where I've been sending emails from.

As I said, I have the Nvidia X Server Setting App installed, the driver says it is Version 465.31. From what I can see it really is a problem finding the libOpenCL.so.1 file. I'm going to slow down here, I've probably driven you all crazy with multiple email sources, and I'm sorry for that.

Regards,
Troy
Screenshot from 2021-06-28 07-04-58.png
Screenshot from 2021-06-28 07-04-58.png (97.87 KiB) Viewed 1155 times
User avatar
admin
Site Admin
Posts: 2861
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: [LINUX] error while loading shared libraries: libOpenCL.so

Post by admin »

Hi Troy,

Try installing the nvidia-opencl-icd and/or opencl-icd packages.
This should hopefully provide you with the required OpenCL library (note the letter C, not G - OpenGL is something different).
Ivo Jager
StarTools creator and astronomy enthusiast
Post Reply