Warp ringing artefacts 1.3 beta

Questions and answers about problems with the software, modules or functionality.
Post Reply
User avatar
Rowland
Posts: 227
Joined: Sat Mar 05, 2011 10:54 pm

Warp ringing artefacts 1.3 beta

Post by Rowland »

Ivo. I have had success with the Repair/Warp module using the latest stable 1.2xx. Using 1.3 I have no control over ringing artifacts. The ringing occurs under the mask. So, no matter what you do with the mask, grow or shrink, the ringing fits the mask size - from what I can see pixel for pixel with the shape of the mask. No idea where I'm going wrong here?

Cheers

Rowland.
User avatar
admin
Site Admin
Posts: 2305
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: Warp ringing artefacts 1.3 beta

Post by admin »

artefact wrote:Ivo. I have had success with the Repair/Warp module using the latest stable 1.2xx. Using 1.3 I have no control over ringing artifacts. The ringing occurs under the mask. So, no matter what you do with the mask, grow or shrink, the ringing fits the mask size - from what I can see pixel for pixel with the shape of the mask. No idea where I'm going wrong here?

Cheers

Rowland.
Hi Rowland,

Could you post an image for me to look at?

It'd be much appreciated!
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
Rowland
Posts: 227
Joined: Sat Mar 05, 2011 10:54 pm

Re: Warp ringing artefacts 1.3 beta

Post by Rowland »

Ivo. I see that you have posted .180. I'll try it first.
User avatar
Rowland
Posts: 227
Joined: Sat Mar 05, 2011 10:54 pm

Re: Warp ringing artefacts 1.3 beta

Post by Rowland »

After Warp
After Warp
WarpAfter.png (85.54 KiB) Viewed 4980 times
OK. No change. I think this is a user generated issue. I'm following the script.

The image is a 50% fit file, reduced from full size immediately following integration of the subs. Opened in ST as a linear image.

Defaults - Develop > Wipe > Contrast > Life (Moderate Optimization) > Colour (+20% saturation) > Tracking off (no noise reduction) > Repair (Warp)...

As shown - standard mask - also tried mask at various growth from the Mask and Warp panels - same result.
User avatar
admin
Site Admin
Posts: 2305
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: Warp ringing artefacts 1.3 beta

Post by admin »

Hi Rowland,

It is probably due to not selecting each star's pixels well enough in the mask. Can you try to make sure every pixel that constitutes starlight for a particular star is selected for that star?
You will indeed see 'borders' where any remaining starlight has not been healed out properly. You'll notice that these 'borders' have the correct background color if that star hadn't been there at all (which is what Repair is going for), but due to remnant halos, these 'borders' stand out.

Does this help?
Ivo Jager
StarTools creator and astronomy enthusiast
User avatar
Rowland
Posts: 227
Joined: Sat Mar 05, 2011 10:54 pm

Re: Warp ringing artefacts 1.3 beta

Post by Rowland »

Thanks Ivo.

I think this is a great result. It was a matter of using the Mask module properly.
RepairAfter.jpeg
RepairAfter.jpeg (201.96 KiB) Viewed 4972 times
Rowland.
Post Reply