Page 1 of 1

Log file not writing.

Posted: Sat Apr 04, 2020 1:31 pm
by mackiedlm
Hi, I am using the latest 1.6.

I'm having a problem with the log file. It does not seem to produce a new log file each time I complete a process. There is atext document called just "Startools" in the correct folder (beside the application file) - there is no "startools.log". The startools file is indeed a log file but it does not change. if I delete it from the folder, then do a process - it then writes a new correct log file (still not a ".log"). Next time I process, the file is not updated so I loose the log of the new process.

Is this correct and do I just have to make sure I remove the text file each time. Or am I missing a setting somewhere.

thanks

David.

Re: Log file not writing.

Posted: Sat Apr 04, 2020 1:38 pm
by admin
Hi David,

That sounds really odd. Are you sure the new log entries are not appended to the end?
Which operating system are you running?
Your OS is likely configured to identify a .log extension as a "Text Document". Revealing the file extensions should show the full file name as "StarTools.log" however.

Thank you,

Re: Log file not writing.

Posted: Sat Apr 04, 2020 2:04 pm
by mackiedlm
admin wrote:Hi David,

That sounds really odd. Are you sure the new log entries are not appended to the end?
Which operating system are you running?
Your OS is likely configured to identify a .log extension as a "Text Document". Revealing the file extensions should show the full file name as "StarTools.log" however.

Thank you,
Hi Ivo

Using Windows 10

No definitely not there. Attached a snip of the folder. Highlighted is the text file containing a process I did today, but that only appeared after I deleted the previous one which was from last week. Despite me having done a couple of full processes since that one. Reveling the extensions has indeed shown the .log
ST log.PNG
ST log.PNG (60.28 KiB) Viewed 1167 times
Thanks.

David

PS This is JockinIreland fro TSS - you helped me last week with my M81/M82 - I'm giving startolls a good try out now!

Re: Log file not writing.

Posted: Sat Apr 04, 2020 2:22 pm
by admin
Hmmm...
I just checked the latest version (1.6), fresh download and can't replicate the problem on my Windows 10 test machine. The StarTools.log file is growing correctly with every module I complete. It will also correctly identify itself in the log (version number + timestamp) every time I launch it.

So you, just so I understand, you are saying that only one session of StarTools will write to the log (if you first delete it entirely), but when you close StarTools it and re-open it for a subsequent session, it will not longer append anything to the log? It will not grow in size? It is now forever stuck at 31KB?

Re: Log file not writing.

Posted: Sat Apr 04, 2020 2:28 pm
by mackiedlm
Yes thats how it seems.

Ill go and do a very quick run through and confirm that.

Re: Log file not writing.

Posted: Sat Apr 04, 2020 2:52 pm
by mackiedlm
OK, so I went in and ran a very quick process of a rosette nebula. (Was coming out nice by the way!!)

Closed down and went back to the startools folder. Now it is showing both the trk and the .log files as having changed at 15.40 or so which looks right. BUT, the .log file is still showing the process from earlier.............oh, wait a minute!!

Ah, OK I'm an idiot -- the new session is showing below the earlier session. I was clearly not scrolling down far enough. And thats what you meant by "Are you sure the new log entries are not appended to the end?" I was looking for an entirely new file, not additional information in the original file.

Most sincere apologies for wasting your time.

I'm going back to make a proper effort on that rosette now.

Apologies again.

David.

Re: Log file not writing.

Posted: Sun Apr 05, 2020 1:08 am
by admin
No problem at all David! You are trying to get your head around the ins and outs of new software. Learning new stuff is quite the opposite of idiocy! :thumbsup:
Any further trouble, let me know. Clear skies!