Workflow and Image quality troubleshooting

Questions and answers about processing in StarTools and how to accomplish certain tasks.
alinderbaum1
Posts: 11
Joined: Mon Mar 30, 2020 8:31 pm

Re: Workflow and Image quality troubleshooting

Post by alinderbaum1 »

Thanks, IVO. I will do that. Thank you for the example. Where should the histogram be after the flat image is captured? Or does it really matter?

Did you have any time to look at the processed image (without the flats) I had in the same link? It looks like it is getting there but something is not quite right. I know I need to invest in a new camera and filter, but want to get the basics down first before the investment.
User avatar
admin
Site Admin
Posts: 2384
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: Workflow and Image quality troubleshooting

Post by admin »

alinderbaum1 wrote:Thanks, IVO. I will do that. Thank you for the example. Where should the histogram be after the flat image is captured? Or does it really matter?
You'll want to aim for a peak about 1/3rd from the left (at your optimal/native ISO), and stack a few of those. Virtually all sensors have a linear response in the first half of the histogram (most modern ones are almost fully linear, but it's just a safe bet this way). The 1/3rd peak thing here is to make sure that the response is linear, e.g. your sensor counts a set amount of electrons for every amount of photons coming in. When a CCD/CMOS well/pixel/photosite starts getting "full" (e.g. close to over exposure) some sensors start counting progressively fewer electrons for the same amount of photons. E.g. linearity goes out the window.
Did you have any time to look at the processed image (without the flats) I had in the same link? It looks like it is getting there but something is not quite right. I know I need to invest in a new camera and filter, but want to get the basics down first before the investment.
Hold off on the investment (unless either are broken of course). It's important you get a feel for what you can achieve with your current gear first on you get it to produce clean data. You may not need/want an upgrade.

What filter are you alluding to by the way? Filters can also be a source of gradients...

With regards to the image you uploaded, you appear to do a lot of things right. It's just that it's very hard for people (and algorithms) to figure out what is real nebulosity and what is artificially introduced light/gradient right now. It's the one thing holding you back!
Ivo Jager
StarTools creator and astronomy enthusiast
Burly
Posts: 240
Joined: Mon Aug 31, 2015 7:06 am
Location: Northamptonshie uk

Re: Workflow and Image quality troubleshooting

Post by Burly »

Rule of thumb Flats in general should be taken at same iso , same focus and set camera to Av mode and let the camera decide best exposure generally histogram should be third in from left on camera screen (usually in the second box ) 1600 iso seems to quick 1/4000 generally is the setting for taking bias frames .
alinderbaum1
Posts: 11
Joined: Mon Mar 30, 2020 8:31 pm

Re: Workflow and Image quality troubleshooting

Post by alinderbaum1 »

Thanks Burly and Ivo!


"It's just that it's very hard for people (and algorithms) to figure out what is real nebulosity and what is artificially introduced light/gradient right now. It's the one thing holding you back"

In regards to the above comment, I feel like I am at a standstill at the moment or not understanding how to troubleshoot. The images I have taken of M42 seem to have good data (or so I have been told by people more experienced that I) but also a bunch of light pollution or other gradients. I am told a light pollution filter will not provide much help because processing software should be able to process out much of this light pollution data. Is this true or is this not accurate?

It does not seem that in this case Startools is able to process out the light, which leads me to believe the data is bad. What do you recommend as next steps in troubleshooting? I have searched extensively for recommendations and guides, but am either not searching with the right key words/topics or something because I have not identified how to troubleshoot this. Unfortunately, my local astronomy group is not well versed in imaging.
happy-kat
Posts: 261
Joined: Sun Feb 01, 2015 11:31 am

Re: Workflow and Image quality troubleshooting

Post by happy-kat »

Could you share a link to the stacked data set of just lights?
alinderbaum1
Posts: 11
Joined: Mon Mar 30, 2020 8:31 pm

Re: Workflow and Image quality troubleshooting

Post by alinderbaum1 »

Here is the FITs of just the lights stacked. The file also has the image I have from my completed Startools processing (using lights, darks but NO flats due to the poor quality)


https://1drv.ms/u/s!At7UzxGKX97o7kvVGS6 ... P?e=jDhbMC
happy-kat
Posts: 261
Joined: Sun Feb 01, 2015 11:31 am

Re: Workflow and Image quality troubleshooting

Post by happy-kat »

In DSS do ensure to select No White Balance
Also check every light frame carefully as there could be a frame with bad jitters on the stars giving trailing as there were strange zig zag marks over the data
In DSS use kappa sigma on the lights and median on the calibration files
Select your best light frame, look at score and FHWM, as the reference frame
Double check your DSS settings

Sorry I could not get much out of that fit file due to the zig zag trails
alinderbaum1
Posts: 11
Joined: Mon Mar 30, 2020 8:31 pm

Re: Workflow and Image quality troubleshooting

Post by alinderbaum1 »

Thanks, Happy Kat. I went over the settings in DSS with Ivo and confirmed those, particularly the No White Balance.

When you say zig zag trails, what do you mean? I ask because I do not see them (or do not know what to look for)
User avatar
admin
Site Admin
Posts: 2384
Joined: Thu Dec 02, 2010 10:51 pm
Location: Melbourne
Contact:

Re: Workflow and Image quality troubleshooting

Post by admin »

alinderbaum1 wrote: "It's just that it's very hard for people (and algorithms) to figure out what is real nebulosity and what is artificially introduced light/gradient right now. It's the one thing holding you back"

In regards to the above comment, I feel like I am at a standstill at the moment or not understanding how to troubleshoot. The images I have taken of M42 seem to have good data (or so I have been told by people more experienced that I) but also a bunch of light pollution or other gradients. I am told a light pollution filter will not provide much help because processing software should be able to process out much of this light pollution data. Is this true or is this not accurate?
That is not quite true or accurate. It is possible to model gradients of celestial origin and light pollution and subtract that model, however the noise from that signal cannot be modelled or removed. A light pollution filter, however, removes part of the spectrum and therefore makes it impossible to display the full color spectrum in your images. Whether that is a problem, is up to you.

To reiterate; gradients on well calibrated data are common and are easily dealt with by modules such as Wipe. However, gradients and dust donuts because of uneven lighting and debris on your lens degrade your signal immensely. They are virtually impossible to model accurately enough to not pose a significant problem. Therefore they must be dealt with by flats.
It does not seem that in this case Startools is able to process out the light, which leads me to believe the data is bad.
In Wipe you can drive up the Aggressiveness (you may need a higher Precision) an mask out dust donuts as a temporary workaround, but they are not viable long term solutions. The data in your stacks (in the form of light frames) is not necessarily bad, it just doesn't seem like it is calibrated correctly thus far.

Just to confirm that Wipe is capable of rescuing something from your lights-only stack;
StarTools_139.jpg
StarTools_139.jpg (344.05 KiB) Viewed 1395 times
Further processing yields this;
Autosave002(7).jpg
Autosave002(7).jpg (241.7 KiB) Viewed 1395 times
What do you recommend as next steps in troubleshooting?
Acquiring and applying flats should be in your search terms. There are different techniques, some people build a light box, some people use the t-shirt method. Some people use an iPad or laptop screen. If one method fails to produce good flats, try another.
When you say zig zag trails, what do you mean? I ask because I do not see them (or do not know what to look for)
The setting happy-kat suggested (e.g. kappa sigma outlier rejection) should have solved the issue with the hot pixels (the squiggles). The shape of the squiggle is a good sign though, it means you are dithering enough (e.g. you are giving different pixels on your sensor the chance to sample different parts of the image - the pattern within which you did that is described by the squiggle). The hot pixels are just not being rejected correctly as I would expect from using a Median or Kappa Sigma Outlier rejection algorithm....
Ivo Jager
StarTools creator and astronomy enthusiast
alinderbaum1
Posts: 11
Joined: Mon Mar 30, 2020 8:31 pm

Re: Workflow and Image quality troubleshooting

Post by alinderbaum1 »

Thanks, Ivo. I am going to re-review all of the tutorials on the website and start from scratch. I know there is a little uneven lighting in my backyard that I need to overcome but there must also be basic items I am overlooking to get good results.

Do you mind sharing the steps you used on the image you processed above? I ask because I am obviously doing something completely wrong. I processed the same lights-only stacked image you used and ran it through the steps I posted earlier and my finished image looked exactly like the stacked image I started with.
Post Reply